• Login or Register Here.
  • Login is located in the upper right corner of all pages.

Announcement

Collapse
No announcement yet.

2008 Kia Spectra No cooling

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cornbinder89
    replied
    If it were mine, I'd pull the compressor, pull the clutch, and if nothing seamed out of place, disassemble the compressor to find the source of the failure, before replacing.
    Remember, we can only react to what YOU observe, If you say the clutch is turning the drive plate, we have to assume it is.

    Leave a comment:


  • davevw
    replied
    Well hey there Cusser! I recognize your name/pic from The Samba where I'm vwwestyman.

    Anyway, it is engaging, confirmed visually. And verified by checking with AC switched off to note that it was no longer engaged.

    Static pressures right now are 89 low side and right at 80 high side. Its currently 75 degrees outside. I started it up earlier and they were similar, and they evened out right around static pressure like yesterday-basically the middle of the two static readings. (Unfortunately, wife took her keys with her when she left for work, and I didn't write the pressures down when I started it earlier.)

    The compressor does not make any kind of noises when it's running.

    Leave a comment:


  • Cusser
    replied
    From your pressures, it appears that the AC compressor drive plate is not turning (not engaging), just the outer pulley is; determine this visually. If so, check voltage to the AC clutch wire. At this point, could be several possibilities, need more information.

    Your static pressures are high enough to activate a functioning pressure switch. NEVER add any sealer or refrigerant containing sealer.

    Leave a comment:


  • Cornbinder89
    replied
    From what I see, the compressor isn't doing anything. However, the condenser will need to be changed if the compressor has shed metal into the system. I'd want to know why the compressor failed.

    Leave a comment:


  • davevw
    started a topic 2008 Kia Spectra No cooling

    2008 Kia Spectra No cooling

    This is my wife's car. I need to get her AC fixed now, so she'll quit stealing my Eurovan! (I got it's AC working thanks to advice from this forum a few months ago!)

    Anyway, I think she said it "suddenly" stopped cooling, but it's hard to know if it just one day quit or perhaps was starting to wear down.

    At that point, I assumed the charge was just a little low, so I used one of those cans from Wal-Mart and tried putting in a little (I didn't put much in, because it clearly wasn't doing anything). That was a few months ago; I haven't done anything since.

    Until today when she asked again for me to get it fixed.

    The engine was still a little warm when I put the gauges on (with my IR thermometer most of the engine bay was between 100 and 115 degrees; the block was still around 145. Ambient temp is 82. Under these conditions, the high side reads 100 psi, low side 115.

    With the engine running and AC turned on (and the compressor clutch does engage), the pressures evened out to about 100 on both sides with steady needles on each gauge.

    I'm thinking probably the compressor needs replaced, but wanted to get you all's opinion.

    Thanks!
Working...
X